Tuesday, June 19, 2012

Blank Page when Publishing a Silverlight App

I just deployed a new Silverlight application to a Windows Server 2003 box as a new website and was surprised with a blank page when I launched the application. No error messages or warnings, just a completely blank page.

A quick web search and I realized I had been here before. You have to register the MIME types, .xaml and .xap, in IIS for the website. I added them for a previous website, but I didn’t add them at the server root.

Simple instructions to add the MIME types to IIS can be found on Jacqui’s Dev Blog under Deploying Silverlight Application - Why Blank?! Note the first blog post comment that suggests adding the additional .xap application/x-silverlight-app and .xbap application/x-ms-xbap MIME types. I didn’t need to add the .xbap to get my application working, but I did need the .xap.

7 comments:

Mani said...

keep update more.. that am doing software development company in chennai india and web site development company in chennai .

Jack Smith said...

This information is very good for user to publishing blank page i like your web link. I like it please post other about Custom proffesional silverlight Web Application Development Services

George said...

Nice post.I like the way you start and then conclude your thoughts. Thanks for this information .I really appreciate your work, keep it up
basic online store

angels said...
This comment has been removed by the author.
Angela Colbert said...

You have shared you great experience. web site development matters is one of the serious matter. i m glad to get this useful tips.
website development company in bahrain

bharat shinde said...

I have read your blog.nice post..keep update.
http://www.aeonit.in/web-consulting.php

Vimax Original Pembesar Mr.P Herbal said...


artikelnya sangat membantu gan thanks for sharing :)